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Introduction

This User’s Manual describes the software and hardware features of the Time Machine I

(TMII),a portable kit designed for programming SiTime field programmable (FP) oscillators. The
Time Machine supports many SiTime oscillator parts, with special socket cards that can
accommodate different package sizes.

Important Notes

Refer to disclaimer section for terms and conditions governing the use TMII and devices
programmed on TMII.

After programming, place samples into an antistatic bag clearly marked "Engineering
Samples."

Samples can only be programmed using specific field programmable (FP) parts for a
given oscillator family. Refer to http://www.sitime.com/fp-devices for more information

on how to select and order FP parts.

Please contact your SiTime sales representative for large volume production orders.

The Time Machine Il has not been tested for EMC compliance, EMI radiation
susceptibility, or any temperature and humidity cycling. The recommended temperature
range is 20°C to35°C.

Package Contents

Your Time Machine Il package consists of the following items:

SiTime Programmer (1 pcs)

Socket cards:

Time Machine Il comes with three different socket cards. Each adapter board includes
two or more sockets for connecting devices in different packages to the main unit for
programming. It is possible to remove and insert devices in the socket while the board is
connected to the SiTime Programmer

3. USB Cable (1 pcs)
4. Quick Start Guide (can also be found here - http://www.sitime.com/tm-um)
5. Samples kit with several devices (enclosed device types may vary;please contact sales for
additional units)
6. Tweezers for handling small devices manually
3lPage
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Figure 1: Time Machine II base unit

Part outline SiT6160DK

Pin1 location ! ° | ® ® |:|

Arrow indicates Pinl A 5. 0x3. 2 ' A 7.0x5.0

(

A 2.0x1.6 2.5x2.0
Figure 3: Time Machine socket card SiT6161DK. Supports 2.0mm x 1.6mm (4-pin) and 2.5mm x 2.0mm (4-pin) packages

SiT6162DK

] P .
A 2.7%2.4 3.2x2.5 A

Figure 4: Time Machine socket card SiT6162DK. Supports G package (2.7mm x 2.4mm 4-pin) and 3.2mm x 2.5mm (4-
pin) packages

(< T35 5]
2.7x2.4 3.2x2.5

Figure 5: Time Machine socket card SiT6163DK. qupports G package (2.7mm x 2.4mm 4 pin) and 3.2mm x 2.5mm (6 pin)
packages

Pagedl
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1 ¥ Channel 1 SiT61650K Channel 2

|

S0T23-5
Figure 6: Time Machine socket card SiT6165DK. Supports S package (SOT23-5) and 3.2mm x 2.5mm (6 pin) packages

Software Installation

Go to web page (http://www.sitime.com/tm-sw) and download SiTime installer. Run

downloaded installer and you will be brought to screen below.

qﬁTime“

www.sitime.com

X

Software Installation
- Time Machine Software

- NET Framework 3.5 Service Pack 1
Time Machine Documentation
- License
- User Manual

- Product Registration 0

‘Web Resources

- Time Machine Information

- Field Programmable Device Information

- SiTime Product Selector

r
[ G ]
[ G ]

- SiTime Performance and Reliability Information

© 2013 SiTime Corperation. All rights reserved.

Press Install button right after Time Machine Software.

Note:

The Time Machine requires .NET Frameworkinstalled on your computer. Install .NET
Framework before installing Time Machine Software. Green checkmark will appear if .NET
Framework will be present on target PC or after installation completed.

o - NET Framework 3 5 Service Pack 1 [[Tostatied |

PageSl|
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4l SiTime Time Machine Setup EI_Iﬂ_hJ 44! SiTime Time Machine Setup EI_Iﬂ_hJ

Welcome to the SiTime Time Machine Instaling SiTime Time Machine @
Setup Wizard

Flease wait while the Setup Wizard installs STime Time Machine.

The Setup Wizard will install SiTime Time Machine on your
computer. Click Next to continue or Cancel to exit the Setup
Wizard, Status: Copying new files

Back Cancel Back Mext

Once installation is completed Time Machine Software version will be displayed.

J - Time Machine Software 224027

Software Installation from File

If you do not have the installation USB Flash drive, you may download Time Machine
software from the TMIl product page on SiTime website. In this case, you should install it by
double-clicking the setup file and following the on-screen installation instructions.

Hardware Connection

Connect the SiTime Programmer to your PC using the USB cable. The power light will be
illuminated.

The first time the SiTime Programmer is connected, the Windows Found New Hardware
notification will appear. Please wait until driver installation is completed.

Click here for status. =% Device driver software installed successfully.

_ J .
[ ‘Il Installing device driver software [ = USB Input Device

~ Y 2 i

Page6l
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Driver Installation

The first time the software is started the driver installation will be required. Time Machine
software will install all required drivers automatically.

Installing drivers...

The Windows Security notification window will appear. Please check Always trust software
from “sitime corp” and press the Install button.

[-7] Windows Security @

Would you like to install this device software?

Publisher: sitime corp

. Mame: 5iTime Corporation LpcDevice

Always trust software from "sitime corp”, [ Install | [ Don't Install

'r' You should anly install driver software from publishers you trust, How can ]
decide which device software is safe to install?

PageTl
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Working With the Time Machine Software

Starting the software launches the main user interface (Ul) as shown in below.

Time Machine View Help

snteravalid” Geperal software help | Program Channel 1
Number Generator = Datasheet [Ch1]

A ¥

l Part Number field I_ .*Please enter a valid Part Number | Program
Channel 2
Part Mumber Generator =—— Datasheet [Ch2] 4

Additional options

A
Tracking ID field lease enter a Tfacking ID (optional)
~  Additional Infprmation
] | |
Part Number Generator button l Datasheet button l Program button

l Message window l

Device status [ Operation indicator ]

The Smart Timing Choice™

User Interface features
The following features are available in the main Ul:

TimeMachine> View Logs — launches the log viewer

TimeMachine>Auto Detect — enables/disables parts auto detection mode
TimeMachine> Settings — launches available part families configuration
TimeMachine>Exit — quits the software

Help>View Manual — opens this User's Manual

Help>Supported devises — shows the list of devices supported by Time Machine

Page8lI
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Help > Register— links to registration on SiTime Corp. website (www.sitime.com/time-
machine-registration)

Help > FP Device Refill — links to Field Programmable Oscillators page
(www.sitime.com/fp-devices)

Help>Get Support — opens your email client with a draft of support request e-mail
Help > Check for Updates — checks for software updates (requires internet
connection)

Help > About - SW/FW versions , only SW version is shown if the SiTime Programmer
is not connected

Device status — shows status of the SiTime Programmer (Connected/Disconnected)
Operation indicator — indicates operation status and results (READY/BUSY/PASS/FAIL)
Message Window — reflects operation result and part detection result.

The main Ul can run with or without the SiTime Programmer connected to the host computer.
This allows you to view the programming log history and get software updates without
connecting the base unit.

Page9l
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Entering Part Number

You may type the SiTime Part Number into the Part Number Field or copy it from another
source and paste.

-

[ SiT&209A1-2F-18E-90.000000 Program

| ‘
Part Number Generator = Datasheet [Ch1]

If you enter a valid SiTime Part Number, the background of the Part Number Field becomes
green. The background will turn red when the part number is invalid. You cannot program the
device with an invalid part number.

Vil
| SiT8209AIE21-18E-90.000000 FP|

Program
Part Mumber Generator =—— Datasheet [Ch1]
|_ thJ |Prngram| ‘

Part Number Generator  — Datasheet |S'|TSEDSM-31—)OO<-D |:||:||_FP1:|||:|C||
]

(*) Time Machine Il software will alert you with this icon if the part you are trying to
program contains non-default drive strength.

(**) With the correct part number in the Part Number Field Time Machine Il software
will automatically detect which FP (Field programmable or “blank”) family you are going to use
to program that part number. If you put a pointer over FP icon a box with blank part number
will appear. More details on FP parts may be found here.

Pagel0l
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Part Number Generator

The Part Number Generator provides an option for generating SiTime part numbers. Click
the Part Number Generator button on the appropriate Channel. Note that you should have a
valid FP part in the specific Channel socket you are entering the part number in. The PN
generator window will appear.

r

518200~ | Part Number Generator

Frequency 90

@ +10PPM| () +20PPM () =25PPM

Frequency Stability
_J £50PPM

Temperature Range -20t0 70 m
Supply Voltage 33V 028y 025V
1 25x2.0mm (@ 3.2:2.5mm| () 50:3.2mm

1 7.0x5.0mm
Feature Pin Q) Qutput Enablej () Standby
DriveStrength = - |

SiTime Part number is:
SiT8209AI-2F-18E-90.000000

Package Size

0K Cancel

Select the desired part family from the drop down list at the top of the Part Number
Generator window. Specify desired frequency and other configuration parameters and click OK.
The generated part number will be automatically pasted into the Part Number field of the
appropriate Channel. The Cancel button returns you to the Channel view without updating the
Part Number field.

Pagelll
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Part Programming

Once you have entered a valid part number, click the Program button to program the part.
The programming process result will be reflected in the output window as shown below.

Please enter a Tracking ID (optional) Please enter a Tracking ID (optional)
~  Additional Information #  Additional Information
04:05:33 Program SiTBO0BAC-31-33E-44.000000( x1 @) Pass(0x00) 04:07:46 Program SiT8208AC-81-33E-70.000000
04:05:35 Verify ~ SiTE008AC-31-33E-44,000000 Pass(0x00) Part is programmed(0x09)
04:07:47 Verify  SiT8208AC-81-33E-70.000000

Fail(Dx11)

m
o

The Smart Timing Choice™ - The Smart Timing Choice™

If part programming is successful the Operation indicator field will show a green PASSED
indicator. If the part programming fails the Operation indicator field will show a red
indicator. In this case, see the"Programming generates a FAIL message"section of this manual
for information about how to proceed. Part Verification is done automatically following any
Programming operation.

During Programming and Verification procedures the active channel window will dim and all
controls in the channel dialog boxes will be disabled. The Operation indicator will read BUSY as
shown below.

The Smart Timing Choice™

Tracking ID

The main Ul includes an optional Tracking ID field to help you track programming history.
After entering the part number but before programming, you may enter a text string to be
associated with the part. This Tracking ID will then be displayed after programming in the Logs
viewer window.

Auto Detect Mode

To enable Auto Detect mode click TimeMachine > Auto Detect. The check mark will be
displayed indicating that Auto Detect mode is enabled. In Auto Detect mode with the SiTime
programmer connected, the software will automatically check for the presence of a part in each

Pagel2l
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Channel and bring up an individual channel view for the appropriate channel. An appropriate
message will be displayed in the Message Window whenever an FP part is detected.

Auto Detect mode can be used for part frequency estimation. If an already programmed
part is inserted in the socket, the message will display the estimated part frequency.

m Time Machine

Time Machine  View Help

| Please enter a valid Part Number I Program
Part Mumber Generator == Datasheet 7.0%5.0mm

Please enter a Tracking ID (optional)

m Time Machine

Time Machine View Help

No FP parts are inserted.

Please enter a Tracking ID (optional)

#  Additional Information

Detected on 7.0x5.0mm[Ch2] Partnumber: Unknown/Programmed
Freq: 26099796 Hz

Additional Information
Detected on 7.0x5.0mm[Ch2] Parthumber: FP Part

The Smart Timing Choica™ . The Smart Timirg Choice™

Note:
Auto Detect estimated frequency measurement result should not be used for part
performance judgment.

Viewing Operation Logs
Time Machine stores records of all parts programmed and you can access them at any time

in order to view programming history. In order to launch the Log Viewer please select
TimeMachine > View Logs on the main Ul.

m Logs viewer _

From To Operstion Operation Result  Tracking ID Parthlumber
ISelectacate [15]| |Selectacate [1a] Al <] fa - [ -
DateTime Operation  Operation Result TrackingID Part No.

| 4/17/2013 12:36:03 PM i Tracking ID was not set. SiTBO04AI-13-255-125.00000 g
4/17/2013 12:36:00 PM | Program Pass Tracking ID was not set. SiTBOD4AI-13-255-125.00000

4/17/2013 12:34:33 PM_ Verify Pass Tracking ID was not set. SiT8208AI-GF-18E-10.000000
4/17/2013 12:34:23 PM _ Program Pass Tracking ID was not set. SiT8208AI-GF-18E-10.000000
3/22/2013 21%:06 PM  Verify Pass Tracking ID was not set. S5iT9121AI-2D2-25E60.000000
3/22/2013 2:19:05 PM__ Program Part is programmed Tracking ID was not set. SiT9121A1-2D2-25E60.000000
3/22/2013 21903 PM_ Verify Pass Tracking ID was not set. SiT9121AI-2D2-25E60.000000
3/22/2013 21858 PM  Program Pass Tracking ID was not set. S5iT9121AI-2D2-25E60.000000
3/22/2013 2:18:08 PM_ Verify Pass Tracking ID was not set. SiT9121AC-2D2-25E50.00000(
Sendlogs || Clearlogs || Cancel

Pagel3l
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Data Log Mode

Data log mode allows storing additional information about programmed parts and order
during batch programming. To switch to the data log mode please select View > Data Log as

shown in the figure below.

m Time Machine 2.26

Time Machine Help
W dassic

S b q Utility

Data Log Utility has fields for entering ordering information, operator lot information and
part number. Fields marked with red asterisk should be filled mandatory. Once required
information is entered, it’s possible to start programming session.

m Time Machine 2.26

Time Machine View Help

l Operator’sname '—

Quantityof parts to be Operator * BD
programmed | Achual Quantity® | 4

' Lot ID '__ L Lot ID * A0004

Data Log Ut"ity [ Sessionstart button I
Start

. X Operation * Program¥sri v
Operation selection == I S v J
- Channel * |Channel_l j
Channel selection PO/Sample
3 1 : b Reqguest Number
ample request number
W Part Mumber * [ SiTZ025AE-52-18E-120.000000 J
Part number field Customer FP Part
Mumber
Customer FP part number
; READY
Message window
: Average Time 0 [ Session end time ]
Mean part programming
time Session Start - Session End - I |

' Session start time I REJECT 0
TOTAL IN: 1] YIELD 0 Yy

PASS: 0

[

Quantity of processed partsw

9 { s s s L
(programmed + failed) - Additioral Informatid Operation indicator J '

Session yield

REABY

m
. Connected
l Device status '— - i
The Smart Timing Choice™ ﬁ-‘

At the beginning of programming session Part Number Generator appears showing decoded

Pagel4dl
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mTime_T“

part number. After pressing OK in Part Number Generator window programming of first part
starts. When part programming is done operator should place new FP part and press
Program Next button. Programming session ends when number of programmed parts reaches
Actual Quantity entered or Stop button is pressed. At programming session end programming
information is stored to the log.

m Time Machine 2.26

Time Machine View Help

Data Log Utility
| £ Opsaratar * Stop
m Part Number Generator
Actual Quantity *
z Program Next
[5772025 -] Part Number Generator T 9
Operation * ProgramVerify
Frequency | 120.000000 e - '
Channel # I Channel_1 'I
Revision Letter B PO/Sample
Request Number
Frequency Stability € £30PPM € £50PPM Part Number * | SiT8004AI-12-28E-125.00000 |
Customer FP Part
Temperature Range 400125 € -55t0125 Number
Ci2sv Cosv Cl30v 33V
Supply Voltage
Cxx
" - - Average Time 2.35
Package Size ¥ S0T23(2.8x2.6mm)
Session Start 6:51 PM Session End
Feature Pin " No Connect
- REJECT 0
DriveStrength I ,l TOTAL IN: 1 YIELD 100 9%
PASS: 1
SiTime Part number is:
= v Additional Information
SiT2025AE-S2-18E-120.000000
ok concet [ 8 Commected
\ The Smart Timing Choica™ p‘

Viewing Data Logs
Data logs can be displayed by opening Log Viewer (TimeMachine > View Logs) and selecting
Data Log tab.

e
m Logs viewer

Data Lag |

Classic Logs

From To Operation Type Operator Name Channel SampleReguestNum! CustomerFPPartnum  PartNumber
fBokecta cate 5| [slecta cate )1 | Bl | | E EN

Customer FP Sample Request  Open Excel
Partnumber  Number File

|Prugramv=rify| SITE004AT-12-28E-125.00000 | Empty

VA0 Actual Operator
MNurmber Quanftity  Name

11/21/2014 6:51:46 PM ‘AIJBD-'I |7dDaeGeh-02dll-=|3 | 4

Channel Partnumber

DateTima Lot ID

| Operation
Type

11/21/2014 6:51:30 PM ADOD4 cB440044-e7d-4at 4 BD 1 ProgramVerify | SIT2025AE-52-18E-120.000000 Ematy Empty (_open )
11/21/2014 6:30:33 PM | sdf aaBcBd1d-ed3c48 | 4 sif 2 ProgramVerify | ST20254E-52-18E-120.000000 | Ematy Empty (Copen D)
11/21/2014 6:30:22 PM | sdf e4ledcEd d157-46) 4 sif 1 ProgramVerify | SIT20254E-52-18E-120.000000 | Ematy Empty Open

11/21/2014 6:02:34 PM ADOD4 | 1374%aSa-715b4¢ 2 BD 3 ProgramVerify | SIT2025AE-52-18E-120.000000 | Ematy Empty  _Open_)
11/21/2014 5:11:33 PM wer fa38bb22-76c3-43( 1 wer 1 ProgramVerify | SIT2025AE-52-18E-120.000000 | Ematy Empty (open )
11/21/2014 5:11:01 PM  wer 20feSe3e-1a2347 1 wer 1 ProgramVerify | ST20254E-52-18E-120.000000 | Ematy Empty (open )

.

P
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Firmware Updates

The Time Machine may require a firmware update. You will be prompted to apply it during
the software launch or when you connect the device.

e
Update notification X

'0' Time Machine firmware needs to be updated.

Press QK to continue
oK |

It is strongly recommended that you perform an update immediately.

Do not close the application until the update process is complete. The FW update process will
start after clicking OK.

Update is in progress. Do not close application!  Update is in progress. Do not close application!
Bootloader: Invoking.. Writing firmware data...

Note:
Windows Found New Hardware notification may appear during the firmware update. In this

case, please wait until driver installation is complete.

Installing device driver software M. SiTime Time Machine I Bootloader
Click here for status. # Device driver software installed successfully.
S =B
Pagel6l
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Software Updates

The software will occasionally check for availability of a new software version. This feature
requires an internet connection. You can check for updates manually at any time by clicking
Help >Check for Updates under the menu in Time Machine software.

m Time Machine
Time Machine View Help

Downloading update information... ‘
|

Connected READY
The Smart Timing Choice™ w‘

If a software update is available, press Yes to download the update. The installation will start

automatically after finishing download process. You will also be notified if your Time Machine
software is up-to-date.

| Update notification X

':o:' Time Machine software is up to date,

Pagel7l
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Troubleshooting

Several common issues may occur while using Time Machine. This section describes how to
address them.

The Time Machine fails to start

Reinstall the Time Machine software. Run TimeMachineSetup.msi from the USB Flash drive
or download from the SiTime site: TMII product page or request the Time Machine software via

email from your local SiTime sales representative.

Programming generates a FAIL message

Make sure you are using an appropriate Field Programmable (FP) part in the correct socket
and that part has not been programmed already. If these conditions are met and programming
fails, try replacing the device.

Reporting a bug

Time Machine has an automatic crash report sending feature. If the system crashes, please
send a report to SiTime. Please provide additional information to help us to analyze and resolve

S -
T L ]
iIme

Time Machine has encountered an error and needs to be closed. We
apologize for inconvenience,

the issue.

The type initializer for 'TimeMachine Helpers.AutoDetectWorker'
threw an exception. -

Please submit the error report by clicking 'Send report’. This will help us
fix the problem as soon as possible. Describe crash precondition if
known (optional):

Your email: (7]

Con't 5eno|

If you find a bug that does not cause the program to crash, or if you have a feature to
suggest, please contact SiTime Support at TimeMachineSupport@sitime.com. Please follow

suggestions in this section before reporting an issue.

Pagel8l
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Disclaimer

1. The Time Machine Il Programmer and associated hardware (henceforth Platform) are
intended for use only with SiTime's MEMS oscillators. This Platform will not program any
other manufacturer's programmable oscillators and no attempt to do so should be
made.

2. The Platform is intended for use for engineering development and evaluation of SiTime's
MEMS Oscillators. SiTime does not guarantee or warranty the devices that are
programmed on this Platform for qualification or production purposes.

3. The Platform should be used in static free environment with good engineering practices.

4. This Platform does not fall under the scope of the European Union directives regarding
electromagnetic compatibly, FCC, CE or UL and therefore may not meet the technical
requirements of these directives.

5. THE PLATFORM AND ITS ACCOMPANYING SOFTWARE AND DOCUMENTATION ARE
PROVIDED ON AN "AS-IS" BASIS, "WITH ALL FAULTS", AND WITH NO WARRANTY
WHATSOEVER. SITIME AND ITS LICENSORS EXPRESSLY DISCLAIMS ALL WARRANTIES,
WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING WITHOUT LIMITATION ANY
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE, AND
NON-INFRINGEMENT. SITIME DOES NOT WARRANT THAT USE OF THE PLATFORM (OR
ITS ACCOMPANYING SOFTWARE) WILL BE UNINTERRUPTED OR ERROR-FREE OR THAT
DEFECTS WILL BE CORRECTED OR THAT THE PLATFORM (OR ITS ACCOMPANYING
SOFTWARE) ARE FREE OF VIRUSES OR OTHER HARMFUL COMPONENTS.

6. The user assumes all responsibility and liability for [the] proper and safe handling of the
Platform and the associated programmed MEMS Oscillators.

7. The user indemnifies SiTime from all claims arising from the handling or use of this
Platform and the associated field programmable devices.

8. Please contact a SiTime representative if you have any issues or problems with using this
Platform.

Pagel9l
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