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1. Introduction

MEZ™ takes its name from the Muses of Greek mythology. A Muse was a goddess who inspired the creation process
for the arts and sciences. Like its ancient Greek namesake, the HEZ™ platform inspires rapid development by
supplying customers with an extensive library of open source software, drivers, and processor support - all under a
common framework. HEZ™ development works on the premise of "design once, reuse many times”. This provides
an open source standard for embedded developers to build upon and support. LEZ™ allows companies to focus on
innovation and on their own value-added applications while minimizing development time and maximizing

software reuse.

The diagram below shows a typical embedded application stack. uEZ™ has three primary categories of components
that help simplify embedded application development:

1. Operating System Abstraction Layer (nEZ™ OSAL)
2. Sub-system drivers (WEZ™ TCP/IP, pnEZ™ USB, uEZ™ Driver)
3. Hardware Abstraction Layer (REZ™ HAL)

Applications

MEZ™MTCP/IP UEZ™MUSB UEZ™ DRIVER

LCD
Touchscreen
File System
12C, SPI, Etc.

LEZ™ OSAL

Iwip

FreeRTOS™

LEZ™ HAL

‘ Hardware Peripheral API ’

Embedded Microprocessor ]

The selection of an RTOS can be one of the most daunting aspects of an embedded system development. With
MEZ™ the primary features of common multi-tasking operating systems are abstracted, thus easing the transition to
an open source or low-cost RTOS. The HEZ™ OSAL provides applications access to the following features in an OS-

independent fashion:

e Pre-emptive multitasking e Queues
e Stack overflow detection e Semaphores (binary, counting, mutex)
e Unlimited number of tasks

The HEZ™ sub-system drivers utilize the OSAL functions to provide protected access to the processor
peripherals. The sub-system driver API functions are typically protocol layer interfaces (TCP/IP, USB, etc)
designed as high-level access routines such as open, close, read, write, etc. where possible.
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The HAL functions provide single-threaded unprotected access to the processor peripherals. Customers can

use the LEZ™ HAL routines provided by FDI or they can write their own. The HAL routines provide for

RTOS/MEZ™ independence and allow portability within a family of processors.

MEZ™ is ideally suited for Embedded Systems with standard features such as:

e Processor and Platform BSPs
(Board Support Packages)

e Real Time Operating System (RTOS)

e Memory Management

e NAND/NOR Flash

e SDRAM and DDR Memory

e TCP/IP stack

e USB Device/Host Libraries

e Mass Storage Devices

e LCD Displays with Touch Screen

e Input/ Output Devices

2. Downloading uez™

Start by downloading the latest version of uEZ™ from https://sourceforge.net/projects/uez/. Unzip to a working folder.

In this document we will use a simple directory structure of /uEZ but the user is free to modify this as desired.

The uEZ™ file directory structure should be as follows:

Directory Description
/Build Projects/makefiles
/Include UEZ™ system files and Config.h

/Include/Device

Device Driver class definitions.

/Include/HAL

Hardware Abstraction Layer (HAL) driver class definitions.

/Include/Types

Common data types used by both HAL and Device Drivers.

/Source Source code
/Source/App User application source code and demos
/Source/BSP BSP generic startup code

/Source/Devices/<category>/<manufacturer>/<device>

Device specific code organized by category (12C, SSP, etc.),
manufacturer, and specific device.

/Source/Library/<category>/<package>

Various support libraries organized by category (graphics, file
system, etc.) and package name.

/Source/Platform/<manufacturer>/<platform>

Platforms/boards code organized by manufacturer and specific
platform build.

/Source/Processor/<manufacturer>/<processor>

Processor specific code in separate directories organized by
manufacturer and specific processor.

/Source/RTOS/<RTOS>/

RTOS source code in separate directories

/Source/uEZSystem

uEZ™ System Core routines



https://sourceforge.net/projects/uez/�

3. Project Configuration

UEZ™ uses a simple one project configuration. Depending on the compiler tools, use one of the following subsections.

Code Red 2.0 Project Configuration

Check Code Red Version
UEZ™ can be built using Red Suite v2.0, or later. Confirm the version by looking at the version in the Start menu.

I T Information 3
L] Red suite v2.0

B Uninstall Red Suite v2.0

Preparing the uEZ™ Source Code
Download the uEZ™ v1.04 source code from http://www.sourceforge.net/projects/uez. Unzip the file to where you will

be working. It should create a folder called /UEZ_SRC.

Find the project you want to build in the Build project. For example, when building the demo source code for the IRD
1.0, you will need to go to /UEZ_SRC/Build/IRD1/CodeRed2/workspace/IRDDemo

Code Red projects are prepared by running a batch file to prepare the directories needed for compiling. Go to
JUEZ_SRC/Build/IRD1/CodeRed2/workspace/IRDDemo and double click on Setup.bat. You should see the following
output on the screen.

& C:\WINDOWS\system32\cmd.exe

Copying Include Files...

Copying Source Files ..

Creating Source Directories ...

The files are now ready to access. Run Red Suite 2.0 and tell it to go to the workspace at
JUEZ_SRC/Build/IRD1/CodeRed2/workspace. For example,

x

Select a workspace

red_suite stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session,

Waorkspace: IE:'de'.-'-a'ork'-J_IEZ_S'-;'N'.,uEZ_SRC'-BuiIcI'\IRD1'\C0deRed2'.,'r\'0rk5pace| j Browse... |

[™ Use this as the default and do not ask again

OK I Cancel
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The following screen should appear:

DC;‘C++ - IRDDemo fSource/Platform/NXP/IRD1.0/NXP_IRD1.0_uEZBSP.c - red_suite - |EI 5[

File Edit Refactor Mavigate Search Project Run Window Help

[ wi - | | eg-8--F-|8-8-|%-0-4-|€ e A e B %> Debug |Hgjcice+
J-_,n T TR
=] ’g ¥ =0 M¥P_IRD1.0_uEZBSP.c &2 = 0| 5% outlin f Make £2 % T O
r* - o e
@] Indudes * File: NXP_IRD1.0_uEZBSP.c M = RDDemo
‘= Debug w
= Indude * Description:
bt BSP startup routines specific to the FDI ARM
= LPC2478 board.
=
[== Platform #* This software and associated documentation files
= Processor * are copyright 2008 Future Designs, Inc. A1l Righk
[Z= UEZSystem * B copyright license is hereby granted for redist
dirs, txt * the Software in source and binary forms, witch oz
-2 Setup.bat # provided that the following conditions are met:
setuplog. bt = - Redistributions of source code must retain
bt notice, this copyright license and the foll
R Redistributions in binary form must reprodu
= notice, this copyright license and the foll
bt documentation and/or other materials providg
= - Neither the name of Future Designs, Inc. nc
3 Quickstart Panel &2 =0 bt subsidiaries may be used to endorse or pron
= = deriwed fram the Safrware withont qw.—u—ifi;'LI
8 start here S < I 0

{2 Problems [ v=| Tasks | B console &2 E|Propem‘eq - Damsheetbrowser} %Debugﬂ ~* B -rj-=08

g Import project(s) from archive (zip)
Mo consoles to display at this time.

Q Build TRDDemo' for Debug
ﬁ Clean 'TRDDemo’ for Debug
% Debug 'TRODemo’

‘M Project wizards ¥
8 Import and Export ¥
=]
[ o 125 IRDDemo | | BDDemo MXP/LPC 1768

Click on IRDDemo in the top left (under Project Explorer) and press F5 to refresh the project. Wait until the indexing
notification at the bottom completes.
To compile, press CTRL-B. If everything goes well, the Console should have the following output:

[ I o ] |

EL Problems é Tasks ﬁ w g i = Properties} ] Damsheetbrowseq 3‘& Debuﬂ =0

C-Build [IRDDema] EREN NN =R
S LA =&

-
Performing post-build steps

arm-none—-eaki-zize IRDDemo.axf; # arm-none-eabi-objdump -h -5 IRDDemo.axf
>IRDDemo.lss

Text data bas dec hex filename

98944 36184 7532 142640 22d44 IRDDemo.axfl

] ===




Debugging with Code Red 2.0
In order to debug, you will need a Red Probe. Connect the Red Probe to the target board (an IRD 1.0 with 1768 in this
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case) and power on the target. Click the debugicon
board.

at the top. The firmware is now downloaded into the target

Click Yes when to the Confirm Perspective Switch dialog. The following screen should now appear:

E Debug - IRDDemofSource{App f Demos [IRDDemo/ main.c - red_suite o [ 4
File Edit Refactor Mavigate Search Project Run Window Help
Itir- e @ s-0-a - | |8 -dl-0 G- 0~ | 35 Debug D@ C/C++
:KSF Debug 3 " Quickstart Paneq = O || 6= variab 2 % Breakw ] Periphw ™ Core 1 @ Quick 1 i Regist} = Modulw =0
“ 6h P |z m « F|iz « 7 0| &R %~
El IRDDemo Debug [C/C++ MCU Application] MName | Value -
=¥ MCU GDE Debugger (2/3/10 11:27 AM) {Suspended) 9= adcDev 0x0
‘ E-"m'? Thread [0] {Suspended) ()= |cd 0x0
w1 main() E: WMyWorkJEZ_SVN\WEZ_SRC\Buld\IRD 1\CodeRed Zyworkspace \IRDDem (= adcRequest L0}
pe| arm-none-eabi-gdb (2/3/10 11:27 AM) (= value 0x0 —
Lol Er\MyWork\JEZ_SYN\WEZ_SRC\Build\IRD 1\CodeRed 2\workspace IRDDemo\Debug \IRDDen g buffer 0x1000441e
)= keypad 0x0
g event 1.3 hal
< | v
=
d | 3 T v
€] Mxp_IRD1.0_uEZBSP.C (@ main.c £3 = O|[ g= outline &2 B R e ¥ =0
I _wuezDevice lcd; ;I string.h =
ADC RequestSingle adcRequest; stdio.h
TUInt32 value: o stdib.h |
char buffer[1024]; UEZ.h
T uezDevice keypad; ™ HALEMAC.h
T_'JezInp utEvent ewvent; uEZI2C.h
MNVSettings.h
> printf ("\f" PROJECT NAME " " VERSION A5 TEXT "\n\n"):; // clear serial scree_J| AppTasks.h
AppDemo.h
// Btart up the heart beat of the LED MNVSettings.h
vavava e e e e 2 B L[R2 PAT A Formd A w A I F TNTANTML AT hd LETARS b hd
a| i » 4 | »
El console 3 3| Tasksw = Problems} M Red Tracew a Memorﬂ K 5% | G 2B & & | A E-r5-70
IRDDemo Debug [CfC++ MCU Application] E:\MyWark\UEZ_SWMYWWEZ_SRC\Build\IRD 1\CodeRed2\workspace \IRDDemao\Debug\IRDDemo. axf (2/3/10 11:27 AM)
=
-
kil 3

[ | Writable | Smart Insert | 39011 | | RDDeme NXP/LPC1768

The debugging session is now waiting for commands. Press F5 to step into a line of code and F6 to step over a line of
code. Press F8 to run the code. Go to Run->Suspend to break at any point. Double click on the left of any line to set a
breakpoint. Press CTRL-F2 to terminate the debug session (click on the C/C++ at the top right to change the perspective
back to before).



Rowley CrossWorks CrossStudio v1.7 Project Configuration

Check CrossStudio Version
uEZ™ is built using v1.7, or later, of the Rowley CrossWorks CrossStudio for ARM® toolset. To confirm the version

number of the tools, go to Help->About in the main menu and the version number should appear in the lower left of the

dialog.

Release 1.7 Build 12
Copyright © 1997 -2008 Rowley Associates Ltd.

Warning: this computer program & protected by copyright laws and international
distribution of this program, or amy portion of it, may result in severe dvil or aim

Build versions of 12 or above are acceptable.

Check Installed Packages
In addition, packages for your target processor(s) should be installed. Go to Tools->Show Installed Packages and see

which packages have been installed. For example,

Installed Packages

The following support packages have been installed, click on the links to get more information on each package and its contents:

Package Version
Embedded Artists LPC2468 OEM Board Support Package 1.3
Generic ARM CPU Support Package 1.2

NXP LPC2000 CPU Support Package 1.18
STMicroelectronics STM32F10x CPU Support Package 1.9
STMicroelectronics STM32F10x-EVAL Board Support Package 1.3

To install @ support package click Tools > Install Package, select the packaage file you wish to install using the file browser and then
click Install.

If doing development for the DK-TS-KIT with the SOMDIMM-LPC2478, the following packages should be installed:
Generic ARM® CPU Support Package
NXP LPC2000 CPU Support Package

If the packages are not installed, go to Tools->Download Packages from Web, download the missing packages, and then
use Tools->Install Package... to install them.



Opening and Compiling uEZ™
Open the project file “uEZ.hzp” in the /uEZ directory. The Project Explorer should appear at the right. The uEz

distribution comes with the uEZ Demonstration Application in the /uEZ/App directory and is configured for the DK-TS-KIT
build for the LPC2478 processor.

If either a different platform or processor is needed, go to File->Open and open file /uEZ/App/App_Config.h. Change
the #define PLATFORM to match the hardware platform name (open file /uEZ/Include/Config.h for a complete list of
platforms).

To compile the code for the first time, select Build->Rebuild uEZ from the main menu. When complete, the output
should report “Build up to date” when done.

Downloading and Debugging uEZ™ on the Target
1) Plug the J-Link device into the PC and install any drivers as directed.

2) Plug the J-Link’s JTAG cable into the SOMDIMM-LPC2478 board at J3.
3) Select Target menu and choose Targets. The following list will appear to the right.

.
=] % e e

% UUSB CrossConnect for ARM

IUSB CrossConnect for ARM-RTCK
#2 Macraigor Wiggler (20 Pin)
#Z Macraigor Wiaaler (14 Pin)

Olimex ARM-USB-OCD

Olimex ARM-USB-TINY

Amontec JTAGkey

xVerve Signalyzer
Luminary USE Debug
STRY-comStick
Seqgager J-Link
& ARM Simulator

4) Right click on “Segger J-Link” and select Properties,
£ %4. |||5°¢ Segger J-Link Properties

Current

Device Type: <none:

J-Link

Curmrent Speed: [

DLL Compile Time: =none:

DLL Version: 0

Fimware: <none:

i Fimware Version: [

i [£] J-Link DLL File: C/Program Files/SEGGER/JLink ARM V372¢/Jlink ARM di
E Speed: 1.000

JTAG
‘83 Idertify Targst: Yes

Loader

i [8] Erase All: No
" |83 Erase All Timeout: 50,000 milliseconds

Target

i [#] Debug Inteface Type: ARM7TDI

83 Memory Access Timeout: 1,000 milliseconds
- [&] Processor Byte Order: Little

i [&] Processor Stop Timeout: 500 milissconds
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5) If this is the first time you are programming with the J-Link on the Rowley Platform, select J-Link DLL File, press
the “...” button and find the file JLinkARM.dII (usually installed in C:/Program Files/SEGGER/”)

6) If programming a blank LPC2478 part, select a Speed of 100. If the LPC2478 has already been programmed,
select a Speed of 1000. All LPC2478's that come with the DK-TS-KIT are pre-programmed.

7) Go back to menu Target and select “Connect Segger J-Link”

8) Press F5 to download the application to the target and start debugging. When the application starts, it will
pause. Press F5 again to start executing the code.

9) To stop at any line of code, right click the line and select Toggle Breakpoint. Execution will stop automatically at
the breakpoint. Press F5 again to continue debugging.

10) When done debugging, select Debug->Stop. The debugger will return to standard editor mode.

11) From this point on, the process is simply a matter of editing code, compiling the code (Build->Build uEZ or
pressing F7), and then returning to the debugger.

4. Questions and Support

For all questions, bug reports and general technical support, go to https://sourceforge.net/projects/uez/ and use the

Sourceforge.net tools or email FDI directly at support@teamfdi.com .

Marketing updates and details on technical support are available at www.teamfdi.com/uez .

Can we use another RTOS?

All LEZ™ components are made to connect through the HEZ™ OSAL (Operating System Abstraction Layer) to the RTOS
ensuring compatibility with many different RTOS's. Currently all u.EZ™ development by FDI is being focused on the
FreeRTOS™ platform since it satisfies the low cost tool requirement because it is “free”. RTOS products from other
vendors can also be used with pEZ™.

Which compiler suites do you support?
Currently, most HEZ™ development by FDI has been focused on the low cost Rowley CrossWorks compiler, but we also
support the IAR EWARM tool suite. In addition, Keil, ARM® RealView, GNU and other compilers can be used with pEZ™.

What debug tools are available?
Since MEZ™ uses the debug tools that are provided in the customers compiler suite, it can be used with any of the tools
listed above.

Which processors are supported?

Even though WEZ™ is processor independent, all of our initial development has been focused on various members of the
ARM Family. We currently support the NXP LPC24xx family, and processors like Cortex™-M3, ARM9®, and other
variations of ARM7® are being added.
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